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Introduction

* QuickPlot is a Scilab module that provides a GUI to quickly create 2D
line plots from data stored in files without writing a code. Its purpose
is to make browsing and comparing a lot of data stored in files, such
as simulation and experimental outputs, easy and quick.

* Requirement: Scilab-6.0 or above (with Tcl/Tk module)
e Copyright (C) 2019 Sky Engineering Laboratory Inc.
 License: GNU GPL v3 or later
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Starting QuickPlot

In Scilab console, enter “quickplot”. The main window of QuickPlot will appear.
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Data file format

Data files that can be imported to QuickPlot are
ASCII files with column-wise numeric data
separated by comma or spaces. Files can have
header rows. If there are labels corresponding
to columns of data present in a single row
within the header, they can also be imported as
variable names.
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Sample data files
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QuickPlot comes with sample data files for users to play with. They are actually simulation results of

a mass-spring-damper system.

v quickplot
etc
help
macros
sampledata
tel

MSD_M1_K5 COpS.csv
MSD_M1_K5_CopTs.csv
MSD_MI_K5_Clplicsv
MSD_M1_K5 ClpS.csy
MSD_MA_K5_Clp25.csv
=| sample_data_filtertxt

=| sample_var_filtertxt
=| sample_varnames.txt
= sampledata.csv
=| sampledata.txt
£l sampledata_with_header.csv

=| sampledata_with_headertxt
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L11,0.8422402,-1.020783
-12,0.8316154,-1.103858
-13,0.8201695,-1.1585008
S14,0.8079219,-1 264101



Importing data from file

From “File” menu, select “Import Data” and
the “Import Data from File” dialog box will
appear. In the dialog box:

1.

Select a file or files by clicking “Browse”
button. Multiple files can be selected as
long as they have the same format.

Enter the number of header rows at “Skip
rows”.

Select “Separator” from “comma” and
“space/tab”.

If you want to import variable names from
a row in the header, check “Import
variable names from row” and enter the
row number at “Row of variable names”.
Click “Import” button.
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Plotting data (1)

Select data and variables from the list boxes and click “Add Curves” button. If there is no figure
previously, a new figure will be created. If there has been a figure or figures already, the new
curves will be added to the current figure, which may be selected using “Current Figure” selector.
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Plotting data (2)
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Multiple data can be selected in the data list box. In such cases, only variables having common
name among the selected data are displayed in the variable list boxes.
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Plotting data in browse mode

If “Browse” check box is checked, plots of selected variables appear in the current figure as soon
as data and variables are selected. Browse mode may be convenient when you want to browse
through data.
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Changing graph property
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Click “Show Property Setting” button to show graph property setting GUIs. Set the graph property
as desired and click “Apply” button. Make sure that the target figure has been selected as the
current figure before applying.
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Importing variable names

If variable names are stored in a separate file, you can import
them after you import data.

From “File” menu, select “Import Variable Names” and the

“Import Variable Names from File” dialog box will appear.

In the dialog box:

1. Select data to which variable names are imported. Multiple
data can be selected as long as they have the same number
of columns.

2. Select a file that contains variable names by clicking
“Browse” button. This file should contain variable names
such that the i-th row contains the variable name for the i-
th column of the data. The number of variable names must
match the number of columns of the data.

3. Click “Import” button.
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Filtering data and variables

You can filter data and/or variables using “glob” matching patterns. Beneath the data and variable
list boxes, check “Filter” and enter a glob pattern. For admissible glob patterns, see “string match”
section of the Tcl manual (https://www.tcl.tk/man/tcl/TcICmd/string.htm). If there are preset
filters, they can be selected from the pull-down menu.
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https://www.tcl.tk/man/tcl/TclCmd/string.htm
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Importing data and variable filters

Preset filters for data and variables can be imported from files. For the data filter, from “File” menu,
select “Import Data Filter”. For the variable filter, from “File” menu, select “Import Variable Filter”.
In both cases, a file-open dialog box will appear. Select a file that contains glob patterns for data or

variable filter.

S =
sample* < Example of filter file contents

o ad

After importing preset filters they are available to be selected from the pull-down menu.
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Renaming data

Data name is initially the name of the file from which the W Hemame Deta - o X

data is imported. You can rename data as desired. Data |sampledata.csv ]
Mew data name

Elther Ok | Apply Cancel |

*  From “Edit” menu, select “Rename Data”.

 Select data in “Data” list box. Right click the mouse
button and select “Rename Data” from the pop-up
menu.

“Rename Data” dialog box will appear.

In the dialog box:

1. Select data to rename.

2. Enter a new data name.

3. Click “OK” or “Apply” button.
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Changing the order of data

You can change the order of data in the data list box.

Either:

From “Edit” menu, select “Permute Data”.

Select data in “Data” list box. Right click the mouse
button and select “Permute Data” from the pop-up
menu.

The “Permute Data” dialog box will appear.
In the dialog box:

1.
2.

Select data to move up or down.

Click either “Move Up” or “Move Down” button
repeatedly until the data comes to a desired position.
Repeat 1 and 2 for other data until the order of data
becomes desirable.

Click “OK” button.
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Displaying data in console

There are two ways to display data in console: B St ez - H X
Select data to show
MSD_M1_KS_Clip25.csv

[ 1] MSD_M1_K5_COpS.csv

o MSD_M1_K5_COpT75.csv
1. From “Edit” menu, select “Show Data” and the MSD_M1_K5_Cip0.csv

“ »o1- . MSD_M1_K5_CipS.csv
Show Data” dialog box will appear.
2. Inthe dialog box, select data and click “Show”.

Show Close

2]

1. Select data you want to display in “Data” list box.
Right click the mouse button and select “Show Data”
from the pop-up menu.
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Deleting data

There are two ways to delete data:

[1]
1.

2]

From “Edit” menu, select “Delete Data” and the
“Delete Data” dialog box will appear.

In the dialog box, select data and click “Delete”
button.

Select data you want to delete in “Data” list box.
Right click the mouse button and select “Delete
Data” from the pop-up menu.

A confirmation dialog box will appear. Click “Yes”
button.
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MSD_M1_K5_CipS.csv

Delete

Close
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Editing variable names

Either:

e From “Edit” menu, select “Edit Variable Names”.

 Select data in “Data” frame. Right click the mouse
button and select “Edit Variable Names” from the
pop-up menu.

e Select variable in “X variable” or “Y variable” list box.

Right click the mouse button and select “Edit
Variable Names” from the pop-up menu.
The “Edit Variable Names” dialog box will appear.

In the dialog box:

1. Select data from the pull-down menu.
2. Edit variable names

3. Click “OK” button.
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Creating variables

You can improvise variables for comparison. el Seeste Manstie - Box
Data IMSD_M1_Ks_C1p0.csv v|
E|ther Wariable name [2*Velocity
*  From “Edit” menu, select “Create Variable”. Eopresson  [2PLT varvalCMSD. MK Crpo.car.Velcity vl )
e Select variable in “X variable” or “Y variable” list box. o« | Apply Cancel |
Right click the mouse button and select “Create \
Variable” from the pop-up menu. A special function “PLT_varval(dataname, varname)” can be used

in “Expression”. This function outputs a column vector of data specified

o ° ) . .
Create Variable dlalog box will appear. by a data name and a variable name. An easy way to insert this function

In the dialog box: is to use “Insert Varval” dialog box, which appears if you right click the
1. Select data to which the variable is added. mouse button and select “Insert varval()” in “Expression”.
2. Enter the name of the variable. S S
3. Enter a valid Scilab expression that generates a
column vector of length equal to the length of other Dotaname  [MSDMIK5 Clpocsr |
variables. e :
4. Click “OK” or “Apply” button. nsert | Cancel |
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Deleting variables

There are two ways to delete variables: = Delete Variable - box
Data MSD_M1_Ks Clplcsy
Select variables to delete
[1] o e2)) o . V24 Tim?'[ﬂ
1. From “Edit” menu, select “Delete Variable” and the osttontml_
“Delete Variable” dialog box will appear.
2. Inthe dialog box, select data and variables and click
“Delete”.
Delete Close

[2]

1. Select variables you want to delete in “X variable” or
“Y variable” list box. Right click the mouse button
and select “Delete Variable” from the pop-up menu.

2. A confirmation dialog box will appear. Click “Yes”
button.
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Editing preset filters

From “Edit” menu, select “Edit Preset Filters”. = Ekt Preset Fiters - b
The “Edit Preset Filters” dialog box will appear. Data filter
. . k.Csw

In the dialog box, add, delete, or edit glob patterns for sanp | ex
data and variable filters.

Variable filter

pos¥

position

Ok Cancel
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Making a curve twinkle

From “Curve” menu, select “Twinkle” and a Scilab
Choose Message dialog box will appear.

. . “ ” —
In the dialog box, select a curve and click “OK” button, or I Figure oo - o X
. Jr{ILF) Y-IIT) BE(E) O
double click a curve. SLEEERIC
Figure Mol Ed
B scilab Choose Message >
MSD_M1_KS_COp5.csv, ::Time [s], y:\Velocity [mis]
— — — MED_M1_K5_CO0p7TS.csv, ::Time [5], y:Welocity [m/s]
m Select acurve to twinkle 1 e MSD_W1_KS_C1p0.esv, s Time [5], y:Velocity [mis]
MSD_M1_KS Clphoey, xTime [] wWelocity [mfs] ] T MG g:‘lEgsc:vwxxTTr:::e[s§S]y3;f\:lec:Z|c:rhEn[1r.:’:;s}
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MSD I"-'11 KE G1p251:3v leme [s] ;-.r‘-.-‘elcuzlty [m;‘rs]
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-0.5—_
s TN
Cancel I\ Ok /\
-— -
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Deleting curves

From “Curve” menu, select “Delete” and a Scilab Choose
Message dialog box will appear.

In the dialog box, select a curve and click “OK” button, or I Fgure o - o X
o JrAILF) U-IT) BE(E) O
double click a curve. Saaalove
B scilab Choose Message x

MSD_NW1_KS5_COpS.csv, ::Time [5], y:\Welocity [mis]
— — — MSD_M1_KS5_COp7S.csv, x:Time [5], y:Welocity [mfs]
----- — MSD_M1_KS5_C1p25.csv, x:Time [s], y:\Welocity [mis]
-------- — MSD_M1_K5_C1p5.csv, x:Time [s], y:\elocity [mis]

n Select a curve to delete

M5D_M1_KE CGlpSesy, xTime [] wWelocity [mis] 1
MSD M1 KA CGop?hesy, xTime [2], wielocity [m/=] 05
MSD M1 kS Glplesy, xTime [g], w\elocity [mf=] 1

MSD_.M‘I._Kﬁ_-G“:IEﬁES'\-'. = Time [s]. wifelocity [mis]
MSD M1 KR GlipSesy, xTime [5], wWelocity [mis]

(
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Exporting curve data to workspace

From chrve” menu, Select ”EXpOft tO Workspace” and d E Scilab Choose Message >
Scilab Choose Message dialog box will appear. B Select a curve to export

. . py ” MSD M1 KE GlpSesy, xTime [£], wWelocity [mis]
In the dialog box, select a curve and click “OK” button, or MSDIE OTpTo oy xTime o] Voot ]

dou ble C||Ck a curve. MSD M1.K501p25133vleme[s]yUelety [ms]
. . i . MSD M1 _KE CGlphesy, xTime [g], welocity [msfs]

A Scilab Multiple Values Request dialog box will appear.

Enter the name of a variable to which the curve data is

substituted and click “OK” button.

Cancel (0] 4

n Scilab Multiple Values Request x

m Enter a variable to which the data iz substituted

Yariable Mame curve_data

Cance|
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