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Introduction
This segmented turning design tool is an interactive free software Scilab application that
makes it easy to specify a workpiece to be turned from shape specification to production of
the segment cut chart. 

This version allows the creation of segmented pieces with solid or  opened  segments or
staves , which can include spacers, zigzags and the realization of the decorations by playing
on the wood species used. 

The software takes care of all the calculations and allows many visualizations throughout the
design, in particular the workpiece turned in 3D. 

This software can be used on most Windows, Linux and Mac OS X systems
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1 INSTALLATION 

1.1 Installation of Scilab

The Scilab software is a very powerful scientific calculation software. It is "open-source" and free. 
It installs very easily on most Windows, Linux or Mac OS X computers It can be downloaded from 
https://www.scilab.org/download/6.1.0 The installation of the Windows version is done by 
executing the downloaded .exe file The installation of the Linux version is carried out by extracting 
the downloaded archive in the directory of your choice with, for example, the 
tar xzf <archive name> instruction.

1.2 Installation of the application « Segmented tuning design »

To install this application you have to launch Scilab. We then obtain the main window of Scilab:

Clicking on the icon  opens the Scilab application manager:
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By clicking on "Domain Specific" we obtain:

Selecting  "Segmented  turning  design"  opens  the  page  describing  the  tool  and  allowing  its
installation:
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Finally, clicking on the "Install" button starts downloading the application and adding it to 
recognized Scilab applications. To complete the installation, quit and relaunch Scilab.

When Scilab is launched, the window below is then obtained:

This application is bilingual French / English, by default the language used is that of the system. 

It is possible to force English by entering the "setlanguage en_US" instruction followed by the enter
key at the "->" prompt of the Scilab window.

The "Segmented turning" menu that appears in the menu bar is used to launch the two components
of the application: the "Profile editor" and the "Rings editor".
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2 THE PROFILE EDITOR

2.1 Launch of the editor
This component allows you to draw the exterior and interior profiles that the workpiece will have 
when turned. Selecting the "Profile editor" sub-menu opens a graphics window. The user must first 
specify the dimensions of the workpiece he wishes to make (height, diameter and default wall 
thickness). To do this, select the "Tools" menu then the "Workpiece dimensions" sub-menu which 
opens a dialog window which allows you to enter these values:

Once these values have been entered, the "Ok" button resizes the graphics window in which the 
user will draw the profiles starting with the external profile.

2.2 Editing the exterior profile
The profile is defined by a Bézier curve, which is constructed by entering a sequence of points 
(nodes) with left clicks of the mouse. The blue crosses represent the Bézier nodes and the red curve 
that emerges as more nodes are added corresponds to the profile. The position of the mouse is 
reported in milimeters in the information zone at the bottom of the window (see the figure below). 

Note that the graph only represents the right profile. 
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The profile can be modified at any
time: 

• Either by moving the nodes:
press the left mouse button on
the node and move the mouse
while keeping the right button
pressed. During movement the
node and the profile are
updated. To end the movement,
all you need to do is release the
right button.

• Either by inserting nodes: left
click at the place where you
want to add the node.

• Or by deleting nodes: Click with
the middle button on the node to
delete<.

It is possible to undo an action (add,
delete, move a node) using the CTRL-z
key combination.

To have a view of the profile only, you
can hide the nodes with the “Hide
nodes” sub-menu of the “Tools” menu.
and display them again with the “Show
nodes” sub-menu.

Installation of Scilab
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2.3 Scaling profiles
It is possible at any time to enlarge or reduce the profiles using the "Resize profiles" submenu. A 
dialog windows allows to specify the vertical and horizontal scale factors. 

2.4 Editing the interior profile

Once the exterior profile has been created,
you can specify the interior profile. To
begin with, you can display the interior
menu by default with the "Show   default   
interior profile" sub-menu. 

This profile is calculated so as to maintain
a constant wall thickness, equal to the
value provided in the initial dialog
window. 

If this profile is fine with you, you can
leave it there and move on to specifying
the rings. 

Otherwise you can edit the interior profile
as you did for the exterior, having
previously activated the "Toggle profile"
sub-menu. the default profile can then be
used as a guide.

2.5 Backup
The "File" menu provides access to saving and reloading profiles: To save the current state of your 
profiles use the "Save as ..." sub-menu which allows you to specify the location and the name of the
file or the "Save" sub-menu which saves the data in the previously specified file or in the default 
Untitled.pf file. 

This backup is essential to be able to move on to the next step, but can also be useful if you wish
to modify the profiles later, you must then reload the backup in the editor with the "Open ..." sub-
menu.
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3 THE RINGS EDITOR

This interactive application allows you to specify the properties of each ring and each segment 
constituting the workpiece to be turned.

3.1 Launch and presentation of the editor
 Selecting the "Rings editor" sub-menu in the menu bar of the Scilab software opens a graphic 
window comprising a menu bar, control panels, a viewing area and a notification area.

Note that you can open multiple editors at the same time.
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3.1.1 The menus

They are located in the menu bar at the top of the window, they are:

• the "File" menu which, as its name suggests, contains sub-menus allowing the import and 
export of data from system files,

• the "Tools" menu with 2 sub-menus allowing the addition and deletion of rings,

• the “Help” menu, this menu opens the help page which contains the information in this 
document in detail,

• the "Demonstration" menu which offers design examples made with the tool. 

These menus and sub-menus will be explained later as they are used.

3.1.2 Control panels

They are located in the left part of the window, they are made up of a set of input areas and drop-
down lists allowing you to specify the properties of the rings and segments.

3.1.3 The viewing area

It is located on the right side of the window. This is where the views of the rings or the workpiece 
are displayed. You can select the view type in the bottom control panel. 

The displayed view is automatically updated when modifying a property. In the case of 3 
dimensional display you can change the point of view with the mouse by pressing the right mouse 
button in this area and moving the mouse. 

If necessary, this view can be exported  with the “Export display” sub-menu of the “File” menu. For
example,  you can export the view to image files (pdf, svg, etc.)

3.1.4 The notification area

This is the area at the very bottom of the window. This zone is used by the software to explain the 
input errors in the control panels. In the event of an error, the corresponding entry area highlighted 
in red and the explanation is displayed in this notification area.

3.2 Loading profiles and specifying default properties
To start the design of the part, you must load the profiles made with the profile editor with the 
"Import profiles" sub-menu of the "File" menu. A dialog box allows you to enter the name of the 
".pf" file, then a second dialog box opens where you must enter the default properties of the rings:
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In the "Height of the rings" input zone, you can:

• either give a single value, if you want all the
rings to have the same height. In this case the
system will deduce the number of rings taking
into account the height of the profiles,

• or give a sequence of values, separated by
spaces (as in the figure opposite) one for each
ring, the first value corresponding to the
ring of the base. In this case, the sum of the
heights you give must be greater than or equal
to the height of the profiles.

The “Fudge factor" entry area corresponds to a safety
margin added on either side of the raw segments. A
zero margin corresponds to the minimum amount of
wood to be removed during turning (see below for an
explanation).

The "Rotation Angle" defines the rotation to be
applied to ring n with respect to ring n-1. This value
should be given as a ratio of 360 ° / N where N is the number of segments of the ring.

The drop-down lists "Segments wood" and "Spacers wood" allow you to choose the values that the 
essence of the segments will have at initialization. Note that all of these values can be changed later 
to refine your design. When you validate your data with the "Apply" button, a sectional view of your
blank with its rings is drawn in the viewing area. The fields of the control panels are initialized.

3.3 Visualizations
The "View type" drop-down list located in the bottom control panel allows you to choose the 
display  that you want to see in the display area. These visualizations allow you to follow the effect 
of your choices on the workpiece during the design or showing some  details like  zigzag design or 
sketch of segments.

3.3.1 2D View

This display shows a vertical section of the workpiece with the raw  rings and the profiles of the 
turned workpiece.  It is useful to see the effects of the number of rings and ring’s thickness on the 
workpiece design.
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The notion of "Fudge factor" is explained by the  zoom around the 4th ring shown below.
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3.3.2 “Raw Ring 2D”

This choice provides a 2D top view of the current ring in its raw state. The figure below shows this 
view for the 5th row of the “Open basket” demonstration.

This kind of view can be useful for the assembly of the rings.

3.3.3 “Raw Ring 3D” and  “Turned Ring 3D”

These visualizations  show   three-dimensional views of the current ring in either their raw or turned
state (some examples will be shown below).

These views allow to interactively change the view angles, with a right button press and drag  in the
“Viewing area”.

3.3.4 “Raw workpiece” and “Turned workpiece"

These visualizations  show  a three-dimensional view of your workpiece  either in its raw state with 
raw rings glued or after it has been turned. 

The figure below shows the “Turned workpiece" for the “Open basket” demonstration.
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These views allow to interactively change the view angles: with  right button press and drag  in the 
“Viewing area”.

3.3.5 “Unrolled”

This visualization  schematically represents all the segments of the part as if it had been unrolled. It 
is an interactive view useful for assigning wood species of the segments in case of complex design 
(see below)

3.3.6 “Element sketch”

This visualization  represents the dimension sketch of the different elements of the current ring. It is
useful for precise cuts of these elements (see below).

3.3.7 “Zigzag design”

This view type  provides the dimension description of the construction of the laminate board and a 
segment of a zigzag ring (see below). 

3.4 Customizing your workpiece
Most of the changes you may need to make to your initial design apply to the "current ring". This 
ring is selected in the top control panel by choosing an index from the "Ring index" drop-down list.

In this same panel you can also modify the
height, the number of segments of the current
ring as well as its rotation in relation to the
previous ring. 
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3.4.1 Play with wood species

There are several ways to assign wood species to certain segments:

• To change the wood species of the segments of a ring, you can select the current ring by 
choosing its index in the "Ring index" drop-down list, then enter, in the "Segment indices" 
input box the index sequence of the segments to which you want to assign an essence and 
finally select the essence in the drop-down list “Essence of segments”.

• The index sequence can be entered with Scilab syntax. For example for a ring of 12 
segments entering 1:12 designates all segments of the ring, entering 1: 2: 12 designates 
every odd segment of the ring and entering 1,3,5 designates segments 1, 3 and 5.

• To obtain the figure below we have specified that a segment on 2 of ring 6 would be in 
Walnut.
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• To create more complex
patterns, you can select the
"Unrolled" view in the
"Select the type of view"
control panel, which
schematically represents all
the segments of the part as if
it had been unrolled. To
modify the wood species of a
segment, just right-click in
the rectangle representing the
segment. A dialog box opens
where you can choose the
essence. To assign the same
essence to other segments,
click with the middle button
in the rectangle of the
segments to which you want
to assign the same essence. 

3.4.2 Insert spacers

Another way to enrich your workpiece is  to insert contrasting wood essence spacers between the 
segments. To do this select the ring on which you want to insert spacers and then enter the number 
of spacers you want to enter in the "Number of spaces" input box. Note that this number must be a 
divisor of the number of segments N because the spacers will be distributed evenly around the ring. 
You then specify the space angle as a ratio of 360 ° / N which will determine the thickness of the 
spacer, you select "Spacer" as "Space type" and the wood species to assign to all the ring spacers.

 

Here is the "Turned Ring 3D" view of ring 4 of
the example above for which we inserted as
many walnut spacers as segments. 
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3.4.3 Insert spaces

For a workpiece in open segmented
turning, you can proceed as for inserting
spacers but selecting "Open" as "Type of
space".

In case you want a number of spaces /
spacers different from the number of
segments the realization of the ring will
require two lengths of segments: one
used on either side of the spaces /
spacers and the other elsewhere.

3.4.4 Insert / delete rings

The "Insert a ring ..." sub-menu of the "Tools" menu allows you to insert a ring above the current 
ring and to specify its height. If adding a ring results in the top ring being beyond the height of the 
part, an error message is displayed and the operation fails. You must then reduce the size of other 
rings or remove another ring before doing the operation. A warning can then be displayed if the 
cumulative height of the rings is less than the height of the workpiece.

The "Delete a ring" menu of the "Tools" menu deletes the current ring. Removing a ring may result 
in a warning message if the cumulative height of the segments is less than the height of the 
workpiece.

3.5 Ring types
There are 3 different types of rings: “Standard”, “Staves” and “Zigzag” the operations described 
above applies to all types except  Space/Spacer for Zigzag. The type of a  ring  can be changed at 
any time.

To select  a ring type, first select the index of the ring and then the ring type “Standard”, "Zigzag" 
or “Staves” in the "Ring properties" control panel. 

These types are described below.

3.5.1 Standard rings

Standard rings are formed with trapezoidal pieces of wood  whose  grain  runs horizontally,  the 
individual pieces are glued end to end to form the ring. 
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3.5.2 Staves ring

The grain in staves runs vertically, and the  individual pieces are glued edge to edge. This type of 
rings are often used for high rings like cylinders, truncated cones, …

3.5.3 Zigzag ring

You can design a ring with a zigzag pattern, for this select the index of the ring and then the ring 
type "Zigzag" instead of "Standard" in the "Ring properties" control panel. 

The second configuration panel then changes to allow you to specify the zigzag properties: 

• The “Zigzag height” gives the distance
between "points" of the zigzag. This
size must be less than or equal to the
height of the segment

• The “Layers thickness” corresponds to
the thickness of the layers of wood
forming the laminated board from
which the segments will be cut. The
stratification is symmetrical so the first
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value corresponds to the central layer, the second to those on either side of the central 
layer….

• For the outer layer, it suffices to give a sufficiently large value, the height actually necessary
will be calculated automatically.

• To assign a wood species to the different layers, you must give the stratum index, then 
choose the species from the drop-down list.

For a ring of 6 segments, a height of 22mm, a zigzag height of 20mm and 3 strata (Cherry: 4mm, 
Sycamore: 4mm and Alder) i.e. a laminated board with 5 layers we obtain the views of the raw ring 
and shot below. Note that each segment is made up of 2 sub-segments. 

For"zigzag" type rings there is an additional "Zigzag Design" view type which provides the 
dimension sketch of the construction of the laminate board and a segment of the zigzag:
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 The red lines represent the cuts to be made.

3.6 Backup
The "File" menu provides access to saving and reloading your design:

To save the current state of your work use the "Save as ..." sub-menu which allows you to specify 
the location and the name of the file. The "Save" sub-menu saves the data in the file previously 
specified in a previous "Save as ..." or in the default Untitled.ts file.

It is always prudent to make backups during the design of your work, so that you can possibly 
go back or guard against the risk of a crash. Reloading a save in the editor is done with the 
"Open ..." sub-menu.

3.7 From conception to realization
When you are satisfied with the design of your workpiece, the application allows you to generate 
the data necessary for the realization:

• The “Export cuts” sub-menu of the “File” menu generates a text file that can be imported 
into a spreadsheet (Excel, Open office, etc.) which explains the cuts required to make the 
different segments. Below is the file generated for the “Bowl with border” demonstration 
after importing into a spreadsheet.
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• The "Export display" sub-menu generates image file (pdf, svg, jpeg, png) of the figure 
displayed in the ”Viewing Area”. The export of the “Raw ring 2D” , “Element sketch” or 
“Zigzag design”  views may be particularly useful at this stage. 

The export of the “Raw ring 2D” view is done at 1:1 scale. Printing this file respecting the 
scale can help to make the ring,

The “Graphic window” export format copy the content of the viewing area  in a standard 
Scilab graphic window. This may allow further modification of the figure.

With these documents, you have all the elements to move on to production in the workshop!
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4 CONTACT

To report a problem, suggest an improvement, please send an email to serge.steer@laposte.net
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