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Introduction

* QuickPlot is a Scilab module that provides a GUI to quickly create 2D
line plots from data stored in files without writing a code. Its purpose
is to make browsing and comparing a lot of data stored in files, such
as simulation and experimental outputs, easy and quick.

* Requirement: Scilab-6.0 or above (with Tcl/Tk module)
e Copyright (C) 2019-2020 Sky Engineering Laboratory Inc.
* License: GNU GPL v3 or later
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Starting QuickPlot

In Scilab console, enter “quickplot”. The main window of QuickPlot will appear.

 QuickPlot A Menu bar - o X
File Edit Curve Help

= gquickplot

Current figure

Data ™ X Variable ¥ Variable Current Figure: selector

/ X variable / Y variable /

. . . Clear Figure
Data list box list box list box ?
Mew Figure
Close All
[ Filter [ Filter [ Filter [ Browse
\ Browse mode
Show Property Setting »» check box




Data file format

Data files that can be imported to QuickPlot are
ASCII files with column-wise numeric data
separated by comma, spaces, or any
distinguishable string of characters. Files can
have header rows. If there are labels
corresponding to columns of data presentin a
single row within the header, they can also be
imported as variable names.

In Scilab, the csvWrite function can be used
to write a matrix into a file in this format.
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Sample data files
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QuickPlot comes with sample data files for users to play with. They are actually simulation results of

a mass-spring-damper system.

v quickplot
etc
help
macros
sampledata
tel

MSD_M1_K5_COpS.csv
MSD_M1_K5_CopTS.csv
MSD_M1_K5_ClpQ.csv
MSD_M1_K5 ClpS.csv
MSD_M1_K5_Clp25.csv
=| sample_data_filtertxt

=| sample_var_filterxt
=| sample_varnames.txt
= sampledata.csv
=| sampledata.txt
£l sampledata_with_header.csv

=| sampledata_with_header.txt

simulation Result
2019-04-118

Time [s],Position [m],Yelocity
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Importing data from file

From “File” menu, select “Import Data” and
the “Import Data from File” dialog box will
appear. In the dialog box:

1. Select a file or files by clicking “Browse”
button. Multiple files can be selected as
long as they have the same format.

2. Enter the number of header rows at “Skip
rows”.

3. Select “Separator” from “comma’,
“space/tab” and “custom”.

4. If you want to import variable names from
a row in the header, check “Import
variable names from row” and enter the
row number at “Row of variable names”.

5. Click “Import” button.
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= |mport Data from File

File C:/sampledata/sampledata_with_varnames.csv
Skip rows 4 il
Separator comma w |

v Import variable names from row

Row of variable names |4 jl

Preview (first file, first 50 rows)

- |

>

Browse

Time [=] Pozgition [m]|Velocity [m/s=s]
0 1 0

0.01 0.5885017 —0.05948508
0.02 0.5980139 —-0.1578813
0.03 0.595548 —0.255101&
0.04 0.5921161 —0.351060%9
0.05 0.8877313 —-0.4856763
0.06 0.5824073 -0.578867

0.07 0.5761589 —0.6705546

Cancel
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Plotting data (1)

Select data and variables from the list boxes and click “Add Curves” button. If there is no figure
previously, a new figure will be created. If there has been a figure or figures already, the new
curves will be added to the current figure, which may be selected using “Current Figure” selector.
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Figure Mo.0
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File Edit Curve Help
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MSD_M1_K5_ClpOicsv F'D-SItIF:-I'I [m] Velocity [m/s N o 5 M1_K5_C1p0.0sv, x Time [, y: Velooity [mis
MSD_M1_K5_C1p25.csv Velocity [m/s] Add Curves I
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Clear Figure 0-:
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. . 0.4
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Plotting data (2)
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Multiple data can be selected in the data list box. In such cases, only variables having common
name among the selected data are displayed in the variable list boxes.

=~ QuickPlot
File Edit Curve Help

v ¥wvariable

ime [5]
Position [m]
Velocity [mys]

¥ variable

Current Figure:

\ Multiple data can be

selected by dragging or
using Ctrl/Shift button

[ Filter

Show Property Setting ==

[ Filter

Time [s]

Position [m]
Velocity [m/s]

”——

Add Curves

- m— =

N~

Clear Figure

Mew Figure

Close All

[ Filter

[ Browse

=

E E?ure No.0

TrAIWF) YU-JUT) REE) TOMHE)

B eSSV @

Figure Mo.0

MSD_M1_K5_COpS.csv, x: Time [s], y: Pasition [m]
— — — MSD_M1_K5_COpTS.csv, x:Time [s], y: Pasition [m]

----- — MSD_M1_K5_C1p25.csv, x: Time [s], y: Position [m]
c——— MSD_M1_K5_C1p5.csv, x:Time [s], y: Position [m]
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Plotting data in browse mode

If “Browse” check box is checked, plots of selected variables appear in the current figure as soon
as data and variables are selected. Browse mode may be convenient when you want to browse
through data.

. _ @ Figure No.0 — [m| X
&= QuickPlot = X IR Y-IUT) REE) TOMHE)
File Edit Curve Help Baag| Vv e
Data v X variable ¥ variable Current Figure:
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MSD_M'l_KE_CUPTE.ES‘M" in '["'] FI I::-E-itil::-rl [I'I"l] MSD_M1_KS_C1p0.csv, x:Time [s], y:Position [m]
ey p—— Pasition [m] . =
MSD_M1_K5 ClpQ.csw Velocity [m/s] Velocity [m/s] 0.8+
MSD_M1_K5_C1p25.csv ¥ Add Curves |
MSD_M1_K5_C1p5.csw o8
Clear Figure 0]
Mew Figure .
Close All
[ Filter [ Filter I Filter ( % Browse )
~ L . T

Show Property Setting >>
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Changing graph property

Click “Show Property Setting” button to show graph property setting GUls. Set the graph property

as desired and click “Apply” button. Make sure that the target figure has been selected as the
current figure before applying.
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Importing variable names

If variable names are stored in a separate file, you can import
them after you import data.

From “File” menu, select “Import Variable Names” and the

“Import Variable Names from File” dialog box will appear.

In the dialog box:

1. Select data to which variable names are imported. Multiple
data can be selected as long as they have the same number
of columns.

2. Select afile that contains variable names by clicking
“Browse” button. This file should contain variable names
such that the i-th row contains the variable name for the i-
th column of the data. The number of variable names must
match the number of columns of the data.

3. Click “Import” button.
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= |mport Variable Names from File — O >

Select data to which variable names are imported

sampledata.csv

Varable name file

Browse

Import Cancel

Time

position < Example of

velocity variable name file
contents
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Filtering data and variables

You can filter data and/or variables using “glob” matching patterns. Beneath the data and variable
list boxes, check “Filter” and enter a glob pattern. For admissible glob patterns, see “string match”

section of the Tcl manual (https://www.tcl.tk/man/tcl/TclCmd/string.htm). If there are preset
filters, they can be selected from the pull-down menu.

e L
File Edit Curve elp
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Current Figure:
Position [m]

NSO M 1_K5_ Clph.csv

MSD_M1_K5_Clp25.csv Position [m]
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WVelocity [m/s] Add Curves
Clear Figure
Mew Figure
Close All
| — - —
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\' *, + [ \ * il
J Clp o I/ JPDS _ ?
_— o am mm e S —
Show Property Setting ==
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Importing data and variable filters

Preset filters for data and variables can be imported from files. For the data filter, from “File” menu,
select “Import Data Filter”. For the variable filter, from “File” menu, select “Import Variable Filter”.
In both cases, a file-open dialog box will appear. Select a file that contains glob patterns for data or

variable filter.

T e
sample®* < Example of filter file contents

dad

After importing preset filters they are available to be selected from the pull-down menu.

Close All

[v Filter [ Filter [ Filter [ Browse

- il

7
l\ sample” !

aaa
N -’
~ -~ -

—_— e =-—
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Renaming data

Data name is initially the name of the file from which the = Rename Data - O X

data is imported. You can rename data as desired. Data [sampledata.csv v]
Mew data name

E|ther' oK | Apply Cancel |

e  From “Edit” menu, select “Rename Data”.

 Select data in “Data” list box. Right click the mouse
button and select “Rename Data” from the pop-up
menul.

“Rename Data” dialog box will appear.

In the dialog box:

1. Select data to rename.

2. Enter a new data name.

3. Click “OK” or “Apply” button.

15
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Changing the order of data

You can change the order of data in the data list box. B Penmute Dot - o X

Select data to move up or down

Either: e tesr " ) MSD_M1_K5_COpT7S.csv Move Up
. From “Edit” menu, select “Permute Data”. MSD_M1_Ks_C1p0.csv i

MSD_M1_K5_C1pS.csw

 Select data in “Data” list box. Right click the mouse
button and select “Permute Data” from the pop-up
menu. =

The “Permute Data” dialog box will appear.

In the dialog box:

1. Select data to move up or down.

2. Click either “Move Up” or “Move Down” button
repeatedly until the data comes to a desired position.

3. Repeat 1 and 2 for other data until the order of data
becomes desirable.

4. Click “OK” button.
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Displaying data in console

There are two ways to display data in console:

[1]

1. From “Edit” menu, select “Show Data” and the
“Show Data” dialog box will appear.

2. Inthe dialog box, select data and click “Show”.

[2]

1. Select data you want to display in “Data” list box.
Right click the mouse button and select “Show Data”
from the pop-up menu.
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= Show Data

Select data to show

MSD_M1_K5 Clp25.csv
MSD_M1_K5 COpS.csv
MSD_M1_K5 COp75.csv
MSD_M1_K5 Clplicsv
MSD_M1_K5 ClpS.csv

Show

Close
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Deleting data

There are two ways to delete data:

[1]
1.

2]

From “Edit” menu, select “Delete Data” and the
“Delete Data” dialog box will appear.

In the dialog box, select data and click “Delete”
button.

Select data you want to delete in “Data” list box.
Right click the mouse button and select “Delete
Data” from the pop-up menu.

A confirmation dialog box will appear. Click “Yes”
button.
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= Delete Data

Select data to delete

MSD_M1_K5 COpS.csv
MSD_M1_K5 COp75.csv
MSD_M1_K5 Clplicsv
MSD_M1_K5 Clp25.csv
MSD_M1_K5 ClpS.csv

Delete

Close
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Editing variable names

Either:

*  From “Edit” menu, select “Edit Variable Names”.

 Select data in “Data” frame. Right click the mouse
button and select “Edit Variable Names” from the
pop-up menu.

e Select variable in “X variable” or “Y variable” list box.

Right click the mouse button and select “Edit
Variable Names” from the pop-up menu.
The “Edit Variable Names” dialog box will appear.

In the dialog box:

1. Select data from the pull-down menu.
2. Edit variable names

3. Click “OK” button.

Table of Contents

=~ Edit Variable Mames — O

Pt

Data MSD_M1_K5 ClpS.csv

it

Variable names [T i me .[S]
Position [m]
Welocity [mfs]

Ok Cancel
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Creating variables

You can improvise variables for comparison. = Creste Vanable - Box
Data |MSD_M1_Ks_C1po.csv v|
Elther- Variable name |2*Velocity
*  From “Edit” menu, select “Create Variable”. cpresson  [PLT varvlCMSD.M1.K5 Ctpo.covVelocity [T}
*  Select variable in “X variable” or “Y variable” list box. o« | Apply Concel |
Right click the mouse button and select “Create \
Variable” from the pop-up menu. A special function “PLT_varval (dataname, varname)” can be used

in “Expression”. This function outputs a column vector of data specified

o H ” . H
Create Variable dlalog box will appear. by a data name and a variable name. An easy way to insert this function

In the dialog box: is to use “Insert Varval” dialog box, which appears if you right click the
1. Select data to which the variable is added. mouse button and select “Insert varval()” in “Expression”.
2. Enter the name of the variable. ST S
3. Enter a valid Scilab expression that generates a
column vector of length equal to the length of other Dotaname  [MSOMIK5.Clpocsr |
variables. sl -
4. Click “OK” or “Apply” button. nsert | Cancel |
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Deleting variables

There are two ways to delete variables: = Delete Variable - box
Data MSD_M1_KS Clplicsw
Select variables to delete
[ 1 ] ] y . ) Tim!e.[ |
1. From “Edit” menu, select “Delete Variable” and the Postioniml
“Delete Variable” dialog box will appear.
2. Inthe dialog box, select data and variables and click
“Delete”.
Delete Close

[2]

1. Select variables you want to delete in “X variable” or
“Y variable” list box. Right click the mouse button
and select “Delete Variable” from the pop-up menu.

2. A confirmation dialog box will appear. Click “Yes”
button.
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Editing preset filters

From “Edit” menu, select “Edit Preset Filters”. =) Echt Preset fifies -0 X
The “Edit Preset Filters” dialog box will appear. Data filte
In the dialog box, add, delete, or edit glob patterns for sanp | o

=F=F: |

data and variable filters.

Variable filter

posE
position

QK Cancel
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Making a curve twinkle

From “Curve” menu, select “Twinkle” and a Scilab
Choose Message dialog box will appear.

In the dialog box, select a curve and click “OK” button, or LR
. TJrdUF) Y-JWT) BEE TOM/T)

double click a curve. % aaalove

n Sc”ab I:hDDSE ME‘SSEgE >< MSD_M1_K5_COpS.csv, ::Time [5], y:Welocity [mis]

— — — MSD_M1_K5_COp7S5.csv, x:Time [s], y:\Welocity [mis]

—————— MSD_M1_K5_C1p0.csv, ::Time [5], y:Welocity [mis]

n Select a curve to twinkle

MSD M1 X5 Glpice, < Time (L el /2] | o e
MSD M1 KG COp?5cey, wTime (] wWelocity [mss] 05 1 I —— -
M50 M1 KE Clplesy, x:Time [s] wielacity [md=] 1
MSD_M1_KE Clp2hcey, xTime [2] wWelocity [miz]
MSD_M1_KE Clphesy, xTime [2], wielocity [ms]
-0.5—_
” = N

1.5
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Deleting curves

From “Curve” menu, select “Delete” and a Scilab Choose
Message dialog box will appear.

In the dialog box, select a curve and click “OK” button, or EE
. TP Y-JLlT) /EE O
double click a curve. JLCEIERAC
B scilab Choose Message >

MED_M1_KS_COpS.cev, x:Time [s], v\ elocity [mis]
— — — MSD_M1_K5_CO0p7S.csv, xxTime [g], y:Welocity [m/s]
----- — MED_M1_K5_C1p25.csv, ::Time [g], y:Welocity [mis]
-------- — MESD_M1_K5_C1pS.csv, x:Time [g], y:\Welocity [mis]

m Select a curve fo delete

MsD_M1 KB Clphecsy, xTime [=], wWelocity [ms=] 1
MSD M1 KB ClpThcey, xTime [=], wWelocity [mdsz] 05 4
M5S0 M1 KS Clplesy, <Time [2], wielocity [mf=] | 1

MSD;MtKE;D“ﬂEEES\-‘. = Time [S]. wifelocity [mis]
MSD M1 _KE Glphesy, xTime (=], wiWelocity [mss]

/
Cancel || OFK )
~_"

0.5 -
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Exporting curve data to workspace

From “Curve” menu, select “Export to Workspace” and a I scilab Choose Message X
Scilab Choose Message dialog box will appear. B Select a curve to expor

. . “ ” MSD_MI1_KE Clphesy, xTime [] wielocity [mss]
In the dialog box, select a curve and click “OK” button, or HSDMIKS Oy Ts v Time o) ety ]

double C||Ck a curve. MSD M1'K561p2533vleme[s];-.r‘-.-‘elnmty [m;"s]
. . . . M=D MK Clphesy, xTime [g], wWelocity [ms]

A Scilab Multiple Values Request dialog box will appear.

Enter the name of a variable to which the curve data is

substituted and click “OK” button.

Cancel (] 4

m Scilab Multiple Values Request >

n Enter a wariable to which the data iz substituted

Yariable Mame curve_data

Cancel
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