Scilab Home Page | Wiki | Bug Tracker | Forge | Mailing List Archives | Scilab Online Help | File Exchange
ATOMS : MinGw toolbox details
Please login or create an account

MinGw toolbox

Dynamic link with MinGW for Scilab on Windows
(854 downloads for this version - 139378 downloads for all versions)
Details
Version
0.8
A more recent valid version exists: 0.10.5
Author
Allan CORNET
Owner Organization
Scilab Consortium - Digiteo
Maintainer
Allan Cornet
Category
License
Creation Date
April 28, 2011
Source created on
Scilab 5.3.x
Binaries available on
Scilab 5.3.x:
Windows 32-bit Windows 64-bit
Install command
--> atomsInstall("mingw")
Description
            MinGW Compiler support for Scilab 5.3 and more on Windows

You need to install MinGW package distributed by Equation Solution

http://www.equation.com/servlet/equation.cmd?fa=programminglog

ftp://ftp.equation.com/gcc

On Windows 32 bits platform
 (* x86) ftp://ftp.equation.com/gcc/gcc-4.5.2-32.exe

On Windows 64 bits platform
  with Scilab 32 bits:
 (* x86) ftp://ftp.equation.com/gcc/gcc-4.5.2-32.exe

  with Scilab 64 bits:
 (* x64) ftp://ftp.equation.com/gcc/gcc-4.5.2-64.exe


            
Files (3)
[54.86 kB]
Source code archive

[96.39 kB]
Windows 32-bit binary for Scilab 5.3.x
Mise à jour du fichier de Description.
[95.69 kB]
Windows 64-bit binary for Scilab 5.3.x
Mise à jour du fichier de Description.
News (0)
Comments (5)     Leave a comment 
Comment from Olaf Bousche -- July 29, 2011, 10:06:23 AM    
Program is excellent but contains a funny bug.

On my system (Windows 7 X64, Scilab 5.3.2):

After installation of the recommended mingw tools and then the scilab mingw toolbox, all
library conversions fail when scilab is restarted. All compilation tests also fail.

The messages are:
Build libscilab_windows.a
Conversion failed libscilab_windows.a

Running mgw_convertScilabLibs() from the scilab command manually fixes this problem. After
that everything runs fine. Perhaps this bug can be fixed in a later version.

Olaf
Comment from Adrien Vogt-schilb -- September 1, 2011, 05:02:42 PM    
Hi
Will this be compatible with gcc-4.5.2 ? and .6.1 ?

Is there any way that someone archives the last mingw compiler compatible with atoms?

Or maybe we could ask equation.com to keep their old release while this atoms package is
updated?
[get_person] Le compte avec l'identifiant 2125 n'existe pas